How To Fix “Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel”?

[ad_1]

Are you having problems with the issue “Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel“? How to fix it? In today’s article, I will provide solutions for you to solve the issues. Please follow the below steps to get the problem resolved now

How did “Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel” occur?

Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel

When you work with PHP, you may get the issue Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel. Don’t worry, we are here to provide you solutions in order to resolve your problem.

How to fix “Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel”?

To Solve Root composer.json, php 7.3 is required. However, your php version (8.0.0), does not meet that requirement. ^8.0″ something pke this. The second solution is to use composer install and face this error. Just run the following command: composer install, ignoring platform requirements.

Solution 1: Update composer.json with php requirements

This error is caused by PHP version definitions in your composer.json file.

"require": {
    "php": ">=7.3",
},

Simply update this requirement to php: “^7.3|^8.0” or something similar.

"require": {
    "php": "^7.3|^8.0",
},

Solution 2: Use the following command

This command will help you if you’re using composer install but you still get this error.

composer install --ignore-platform-reqs

Final words

The above are useful solutions that can help you fix “Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel” problem, if you can’t solve it well. Please leave a message.

[ad_2]

Source link